S3 Service Performance Degradation

Incident Report for Pilvio

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 11:22 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 15, 2025 - 11:00 EEST

Identified

We have identified the root cause of the performance degradation affecting the S3 service. Our engineering team is currently deploying a fix to mitigate the issue. We will provide another update as soon as the remediation is complete and we begin to monitor the recovery.
Posted Aug 14, 2025 - 16:56 EEST

Investigating

We are currently investigating an issue causing degraded performance for the S3 service. Customers may experience increased latency and intermittent errors when accessing objects. Our engineering team is actively working to identify the root cause.
Posted Aug 14, 2025 - 16:30 EEST
This incident affected: Storage Vault (S3).